Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Table of Contents

Product overview

FIXEye is a multi-purpose FIX session surveillance and visibility platform.

FIXEye presents search results in an easy to work with form. It has an intuitive graphical user interface and uses many operational features familiar from MS Excel.

FIXEye can process multiple log files distributed on the network.

FIXEye features

The FIXEye platform includes the following features:

  • Search for FIX log files on a local computer and a whole network
  • Show FIX messages in a table
  • Select FIX fields to be shown in a table
  • Show FIX field names, values and descriptions
  • Distinguish FIX messages received messages received from the "in" and "out" log files
  • Filter FIX messages by particular text in fields
  • Recognize all FIX versions from a log file
  • Support Regular expression
  • Read raw FIX messages from any text files (not cleaned FIX-logs only)
  • Filter FIX messages by sessions
  • Provide context search
  • Create custom views
  • Create custom filters
  • Validate FIX messages
  • Compare FIX messages
  • Support FIX dialects
  • Provide Order back trace
  • Support Multi-tab view
  • Export selected cells to CSV

FIXEye main window

Image Removed  Components of FIXEye's main window are indicated in the screenshots below:

Image Added

Image Modified

Starting FIXEye

Quick start

  • To start FIXEye, click Start, point to All Programs, click B2BITS, and then click FIXEye. You can also double-click the FIXEye icon.
  • To choose data files, on the File menu , click Open Log Files, select files with raw FIX messages and click Open.
  • Write a search query in a search box and click Search.
  • Double-click on a message in the table to see FIX message details.

At the very beginning FIXEye displays a dialog form for opening log files. You can either browse for files by clicking the corresponding step or skip this step by clicking the Cancel button.

Open file

On the File menu, click Open Log Files or Open Log Folder.

Image RemovedImage Added

You can also use the button on your toolbar.

Image RemovedImage Added

Open multiple files with FIXEye

A user can use the "Send to" Windows function to "send to" files for opening them opening files in FIXEye.

  • Right-click a folder, point to Send To, and then click FIXEye. (it This can be done for multiple selected files.)
  • The selected files will be opened in a new instance of FIXEye.

Image RemovedImage Added

Multiple tabs

FIXEye allows creating multiple data windows (tabs). It is possible to specify different search text, filter, and view for each data window.

  • To add a new tab, click the New Message View button. You can also press Ctrl+T.
  • New data window with a clear search box will appear next to the current one.Image Removed

Data search

Interface

Select the type of message you want to find, type your search query in any search box in the main window and hit the Search button.

Image Removed

You can stop the search process Image Added


Search with FIXEye

Search methods

FIXEye has several ways to search messages in the files:

  • Show all messages
  • Use pre-defined filters for searching
  • Search and filter messages by a tag-value pair
  • Context search
  • Search inside the message
Info

The search process can be stopped by clicking the Cancel button on the status bar.

Tag=value search

If  tag=value constructions with or without regular expressions are detected in search string then all other text is ignored and the searching engine uses only these constructions. Such searching mode is similar to a filter. Messages are parsed one-by-one, search criteria are applied and message satisfying search criteria is displayed. If some preliminary filter is set then search criteria derived from search string analysis is added to the preliminary filter and the result filter construction is applied to FIX message. 

Warning

All unnecessary text before the tag will be ignored, but after tag value, there must be a space character. All other symbols will "spoil" the search string and tag=value construction will not be detected. For example "asdf34=1" will work as "34=1" and "34=1asdf" will not work

...

Info
Search is case sensitive. 

Examples for this type of search are present in the table below.

Examples

...

query type

...

test example

...

screenshot

...

query: 35=d

...

Image Added

Show all messages

FIXEye searches for all FIX messages in the specified files without any additional filtering.

Image Added

Use pre-defined filters for searching

Pick a filter from the list and search for specific message types.

Image Added

For details, refer to Pre-defined filters.

Search and filter messages by a tag-value pair

FIXEye can search for messages by a tag-value pair. Values, in this case, are treated as whole words. 

Info
Search by tag-value pair is case sensitive.

FIXEye also accepts regular expressions for this search method, for example: "35=[A58]".

This type of search can be combined with using pre-defined filters, which makes it the fastest way for searching messages. Search by tag-value pair has priority over other types of search, so only tag-value expressions will be used for the search.

Text other than FIX messages is ignored by FIXEye.

Info

The given search method requires the actual version of FIX dictionary. Otherwise, search by custom tags will not return any results!

The given search method doesn't work with repeating groups. Please search by context instead.

The space character acts as the logical operator AND. For searching a tag-value pair in which the value is represented by integral word-group, the space character should be preceded with backslash  ('\') symbol, for example: 

"58=Unknown\ Reason".

Regular expressions should be used for the logical operator OR

Examples

Case 1. Search by a single tag-value pair

Query: 35=d

Explanation of search query: Only messages where condition 35=d is true will be displayed in the output

Image Added

Case 2. Search by two or more tag-value pairs

Query: 35=d 34=6

Explanation of search query: Tag-value pairs are separated by the space character. Only messages where condition 35=d is true

...

and 34=6 is true will be displayed in the output.

...

Image Removed

...

query: 35=d 34=6

only messages where condition 35=d is true and 34=6 is true are displayed in the output

...

Image Removed

Image Added

Case 3. Search by a single tag-value pair where the value is represented by integral word-group

Query: 58=Unknown\ Reason

Explanation of search query: For searing "Unknown Reason" in Text (58), the backslash symbol precedes the space symbol, not to interpret the space as a the logical operator AND.

Context search

Context search means that all input in the "search box" is considered as to be plain text. It is divided into text patterns search queries according to some the rules described below and these patterns . These search queries are searched for in the input log file. First a text put in the “search box” is analyzed.

 A text Text in quotes (" ") is considered as one pattern search query and is taken as exact the integral text phrase for the searching search engine. The input text is divided into many patterns queries when space characters are met. Each pattern query is searched. Space Here, the space character here means the OR logical operator. Plus The plus character (+) at the beginning of pattern a query is used for to indicate the logical AND operation. That means that searching <pattern1> <query1> +<pattern2> <query2> will lead to success only if both pattern1 query1 and pattern2 query2 are found in the input stream.

Warning
If only +<pattern>  <query> is present in the search string, then no matches will be found even if <pattern>  <query> is contained in the input stream

Context search differs from the search by a tag

...

-value

...

pair.

...

The entire input stream is analyzed, and the results are shown only at the end. Note, context searching may take a long time if the input file is big!

...

You can click the Cancel button at the bottom of the page to stop the process. 

Searching

...

for search queries in a FIX message is more complicated than the ordinary plain text search. First

...

, the search engine looks for

...

search queries in a raw

...

FIX message. Then

...

the FIX message is parsed

...

and tag IDs are converted to names, (e.g. 35=A

...

is turned to MsgType=A) and the search engine looks for

...

search queries again. And for the third time

...

, search tag values are converted to text equivalents, (e.g. 35=A is turned to MsgType=Logon).

...

At the display step

...

, all FIX messages satisfying search

...

criteria are displayed. 

Info
Context search is case insensitive.

Examples

...

Examples for this type of search are present in the table below.

...

Query Type

...

Test Example

...

Screenshot

...

query: heart

...

Examples for the context search method can be found below.

Case 1. Search by a single one-word query

Query: heart

Explanation of search query:  Messages with the "heart" query have been found in 35 tag and 108 tag

...

Image Added

...

Case 2. Search by several queries in a row delimited by spaces, no quotes used

Query: heart security

Explanation of search query:

...

  All messages have been displayed where "heart" or "security"

...

query have been found

are displayed

...

Image Removed

...

Image Added

Case 3. Search by a single multi-word query, enclosed in quotes

...

Query: "list of securities"

...

Explanation of search query:  All messages have been displayed where the integrated "list of securities" query has been found

are displayed

...

Image Removed

...

query: security +gas

...

Image Added

Case 4. Search by several queries in a row delimited by " +" character, no quotes used

Query: security +gas

Explanation of search query:  All messages have been displayed where "security" and "gas"

...

in a single word-group have been found

...

displayed

...

Image Removed

...

Image Added

Data search + pre-defined filter 

It is sometimes useful to do some preliminary filtering and start searching

...

within the filtered results

...

. For more information on

...

pre-defined filtering, refer to Pre-defined filters.  When the filter is set and

...

Search within message details

You can search for message tags and values in the Message Details window.

  • For searching by tag, enter the tag name plus the equal sign ("=") in the search text box and press Enter.
  • For searching by value, enter the value name without any additional symbols and press Enter.

 Image Removed

You will see the search results in the tag table and in the field with the selected message in the raw format.

Image Removed

The field that displays the message in the raw format can be expanded and collapsed. Use the Image Removed and Image Removedicons at the upper right corner of the field for that.text is entered in the search box, FIXEye will first apply the filter and then search the filter's output.

Search within message details

You can search for a specific context in a raw message.

  • Double-click on a message to open the Message Details window and enter your search query in the search text box.
  • Press Enter to go to the next search result or Shift+Enter to return to the previous one.

Image Added

FIXEye-Splunk integration

Some basic capabilities for searching in the Splunk system using FIXEye have been introduced (since 4.1 version). See See How to use FIXEye-Splunk integration capabilities article.

Messages


Agent

This section describes:

  • how to add an agent
  • how to rename an agent
  • how to remove an agent

You can use an agent to browse log files on a remote computer if direct access to the machine is prevented due to security or other issues.

Add an agent

Please note that the agent should already be installed, configured and able to run on the remote computer.

...

  1. Right-click anywhere in the Files window, then click Add Agent in the right-click menu.
    Image RemovedImage Added

    You can also use the Add Agent button.
    Image RemovedImage Added

  2. In the Add Agent dialog, define your connection parameters, such as Name, Host, Port, Login and Password. If you need to connect the agent immediately, select the "Connect now" check box. Make sure the name you choose has not been used before. Otherwise, you will get the warning message:    "The agent with the entered name already exists." 
    Image RemovedImage Added
  3. Click Add to save your agent settings.


If "Connect now" is selected, the connection is available, and everything is set up properly, your agent will launch and its status will change to “Connected”.

  • You can see which files you can browse and what dictionaries the agent uses in the corresponding sub-lists.
  • You can only browse static files. No changes in logs will be reflected.
  • If you want browse logs in real-time, please see the Watch section.

Image RemovedImage Added

Rename an agent

You can rename your agent at any time. To rename an agent, perform the following steps:

  1. Select the Select the required agent and click Edit Agent in the right-click menu.
    Image RemovedImage Added
  2. Enter a new name in the Edit Agent dialog.
    Image RemovedImage Added
  3. Click Save to finish renaming. Your agent is renamed.
    Image RemovedImage Added

Another option to rename an agent is to select it and click it once to apply the 'in place' editing mode. Then you can change agent's name and press <Enter> to save your edits.

Remove an

...

To remove an agent, select the required agent and click Remove Agent in the right-click menu. 

Image Removed

...

agent

...

Message details

To view message details:

  • Right-click the selected FIX message, and then click Show Message Details, or use the F3 key. You can also double-click the selected FIX message.

Image Removed

The Message Details window has the following view:

Image Removed

Paste a message

You can paste a FIX message or the sequence of FIX messages from the clipboard or type them manually in the new data window (tab) to process the message.

To paste a FIX message:

  1. Open the new data window.
  2. Paste the copied message (or some text with the part of the message, or sequence of messages) into it.
    Image Removed
  3. Click OK to process the message.

You can type your own message manually in the new data window with observing proper FIX message syntax. Use the SOH button to insert the Start of Header separator.

The pasted messages are processed the same way as messages taken from the log file or from the agent.

Image Removed

If the entered string doesn't fit validation rules, then the warning message is shown according to the FIXEye error handling rules.

Image Removed

On hovering the warning icon, the error message is popped up. You can also find out an error explanation by selecting the Errors tab as shown below.

Image Removed

Modify a message

The parsed FIX message or sequence of messages can be modified.

  • Select the required message and go to the Raw Message tab. Here you can edit the message content in the RAW format.
    Image Removed
  • Make the necessary changes and click OK to process the modified message.

...

To remove an agent, select the required agent and click Remove Agent in the right-click menu. 

Image Added

Confirm deletion in the Remove Agent pop-up dialog by clicking Yes. Your agent is removed.

Messages

Message details

To view message details:

  • Right-click the selected FIX message, and then click Show Message Details, or use the F3 key. You can also double-click the selected FIX message.

Image Added

The Message Details window has the following view:

Image Added

Paste a message

You can paste a FIX message or the sequence of FIX messages from the clipboard or type them manually in the new data window (tab) to process the message.

To paste a FIX message:

  1. Open the new data window.
  2. Paste the copied message (or some text with the part of the message, or sequence of messages) into it.
    Image Added
  3. Click OK to process the message.

You can type your own message manually in the new data window with observing proper FIX message syntax. Use the SOH button to insert the Start of Header separator.

The pasted messages are processed the same way as messages taken from the log file or from the agent.

Image Added

If the entered string doesn't fit validation rules, then the warning message is shown according to the FIXEye error handling rules.

Image Added

On hovering the warning icon, the error message is popped up. You can also find out an error explanation by selecting the Errors tab as shown below.

Image Added

Compare messages

You can compare two messages tag by tag in a separate window.

  • Select a message, and then hold down Ctrl key while you click other message you want to select.
  • Right-click the selected message , and click Compare Messages.

Please note, that if you select more than two messages, FIXEye will compare only the first and the last one.

Image RemovedImage Added

You can exclude separate tags from the comparison.

...

= values are identical
<> values are different
<= tag is present only in the left message
=> tag is present only in the right message

Image RemovedImage Added

Compare files

You can compare two log files message by message using our new Files Compare tool.

  • On the Tools menu, click Files Compare.
  • Click the Browse at the end of each line to select the files you want to compare.
  • Click the Compare.

“<>” indicates that messages are different

  • Click the <> to compare 2 messages in a new window.

Image RemovedImage Added

Sort messages

You can sort messages by the chosen tag in ascending or descending order.

  • Click the appropriate table column header to sort messages.
  • The direction of the arrow next to the header name indicates the direction of the sort.
  • You can reset current sorting by pressing <Esc>.

Image RemovedImage Added

Message auto filter

You can use different filters to show or hide specific messages.

  • Click the arrow next to header name, and then select a required value to apply auto filter.
  • To reset filtering, select (All).

Image RemovedImage Added

  • Click the arrow next to header name, and then select (Custom).
  • Set up a condition operator and a criterion <value> to compare the current FIX field with some value(-s).
  • The filter criteria can either be selected from the drop-down list or entered by the user.

Image RemovedImage Added


Additional tools

Watch

FIXEye provides a powerful real-time monitoring tool which is Watch. You can create multiple processes with various filters and search parameters to follow updates in selected files.

  • To create a new Watch, on the File menu, click Create Watch. You can also click the Image Modified icon  icon on the toolbar to open the Realtime Files Watch window.

Image RemovedImage Added

  • Specify the message type you want to watch in the Filter list.
  • In the Search box, type search parameters. You can leave the box empty to see all messages.
  • In the Validation list, select a required validation level.
  • In the Check interval box, type a check interval in milliseconds.
  • In the Schedule list, select the moment when you would like to start.

Image RemovedImage Added

  • To add files you want to watch, under Files, click Open. Select files you want to monitor, and then click Open. You can also add files to the list by typing a file path, and then click Add.
  • To remove a file from the list, select a required file, and then click Remove.
  • Select the 'E-mail Notifications' check box if you want to receive a notification email every time a new message is detected. Click Configure to set up an outgoing mail server.
  • Select the 'Activate on new message' check box if you want FIXEye to blink on a taskbar when a new message is detected.

Image RemovedImage Added

You can stop or pause the process in the Realtime Files Watch window using the corresponding buttons on the Watches toolbar.

  • Click the Now Scroll is: Off to switch off the automatic scroll to the latest messages. Clicking the Now Scroll is: On button will restore it.
  • Click the button on the toolbar to clear the list.

Image RemovedImage Added

You can add an agent to monitor the files on a remote computer.

  • In the Realtime Files Watch dialog, right-click anywhere in the Files window, and then click Add Agent. You can also use the button. Please mind that the agent should already be configured on a remote computer.
  • Once the agent is connected you can add a Watch that will monitor the remote storage.

Image Removed Image RemovedImage AddedImage Added

FIX Events Viewer

...

  1. On the Tools menu, click the Events Viewer. You can also use the Events Viewer button on the toolbar.
  2. In the FIX Events Viewer dialog, add files or agents you want to track.
  3. Create a subscription.

Image RemovedImage Added

Click the button on the FIX Events toolbar and select your subscription type.

Connection status

Specify the expected FIX connection status for notification.

...

Image Added

Order acknowledge time

FIXEye can compare the time from SendingTime (52) tag between order and the first acknowledgment on it. This check can be used if one needs to monitor delays in message processing.

...

Image Added

Note
The precision between order and acknowledgment can be different (e.g. Milliseconds vs microseconds) which leads to unexpected/wrong results. Use this option only in case of the same accuracy.Delayed Order Acknowledge is calculated based on the first response time, regardless of his status: new, partial fill, fill or even rejected.

Configuring Email notifications

To receive an email notification on Select the E-mail Notifications checkbox and click on the Configure to set up an outgoing mail server.

Image RemovedImage Added


Interface

File list

All opened log files are listed in the Files window.

  • Select the respective file checkbox to include the file content in the next search.
  • Clear the respective file checkbox to exclude the file content from the next search.

Image RemovedImage Added

Dictionaries list

...

  • To add a dictionary file, on the File menu, click Load Dictionaries.You  You can also click the Image Modified icon  icon on the toolbar. The  The third option is to right-click anywhere on the Files pane, and then click Add Dictionary(ies).Image Removed  Image Removed   Image Removed

Image AddedImage AddedImage Added

  • To remove a dictionary file, right-click the selected file, and click Remove Dictionary(ies).

...

Sessions list

All sessions found in opened log files are listed in the Sessions window.

  • Create groups to sort your sessions using a right-click menu.
  • Select a session check box to include the respective session in the next search.
  • Clear a session check box to exclude the respective session from the next search.

Image RemovedImage Added

Customizing interface

...

  • Tab-dock windows to the search result frame.
  • Dock tool windows to the edge of a frame in the FIXEye.
  • Float windows over or outside the FIXEye.
  • Minimize tool windows along the edge of the FIXEye.

Image Removed   Image RemovedImage AddedImage Added

Tool windows can be docked to one side of a frame in the FIXEye:

  • Drug the window toward the middle of FIXEye window. Three arrows appear and point to the three edged of FIXEye window. The diamond only appears when you drag the window toward another tool window.
  • When the window you are dragging reaches the location where you want to dock it, the designated area is shaded.
  • To dock the window in the position indicated, release the mouse button.

Image RemovedImage Added

Tool windows such as Files and Sessions support a feature named Auto-Hide. When a window is auto-hidden, its name and icon are displayed on a tab at the edge of the FIXEye.
To turn on Auto-Hide:

  • Click the tool window you want to hide.
  • Click the pushpin icon on the title bar of the window.

Image RemovedImage Added

To Turn off Auto-Hide:

...

  • Drug the tool window to the location you want.

Image Removed

...

Image Added

Pre-defined filters

You can use different filters to show specific messages only.

...

  • To create a new filter, click <New>.
  • To modify the selected filter, click the Edit button.
  • To remove the selected filter, click the Remove button.
  • To reset the current filter, click [Default Filter].

Image RemovedImage Added

When you are creating a new filter, you may indicate one or more conditions.

...

Image Added

You can save a back copy of the current filter by clicking button in the Filter window.

...

Image Added

You can address a field tag, which is a part of a repeating group while creating a new filter.

  • Type a repeating group tag, then type a dot character “.”, and a field tag. For example, 453.452 indicates that messages with a repeating group tag of 453 that includes tag of 452 will be filtered.

Image RemovedImage Added

Custom view

You can customize a message view (a set of displayed columns) in the table.

...

  • To create a new view, click <New>.
  • To modify the selected view, click the Edit button.
  • To remove the selected view, click the Remove button.
  • To reset the current view, click [Default View].

Image RemovedImage Added

The “Compact” preset view allows showing messages in a compact form, i.e. numbers for tags and values without description.
The “Detailed” preset view allows showing maximum information about messages. All tag names except service fields are displayed and all field values are described.
The “Raw Data” preset view allows displaying messages in their raw view, i.e. as a row of symbols.

...

Image Added

The “Colored” preset view allows displaying messages in different colors, i.e. a particular color is assigned to every message type, to facilitate visual perception of table data.

...

Image Added

When you are creating a new view, you may indicate one or more conditions. Use to add fields and formatting rules and to delete them.

...

Image Added


Validation

Message validation

You can validate messages in the table against FIX rules.

  • Click n and choose the validation that you want.

Image RemovedImage Added

There are 3 levels of validation:

  • Well formed – message length and checksum match the corresponding field values
  • Well formed and required fields – the same as above and all mandatory fields are present in a message
  • Well formed and required fields and correct values – the same as above, plus message fields have correct values (e.g. the numeric field has a numeric value, the date field has some sensible date, etc.)

Invalid messages are marked in the table with icon.
Related error descriptions are placed into the Errors tab of this data window.

  • Double-click the icon to see the detailed description of an error.

Image RemovedImage Added

Order backtrace

...

  • Right-click on the selected message, and then click Order Backtrace.

Image RemovedImage Added

Click on a message or a state shape to see the related object details.

Image RemovedImage Added

Session backtrace

...

  • Right-click on the selected message, and then click Session Backtrace.

Image RemovedClick on a message or a state shape to see the related object details.

Image Added

Click on a message or a state shape to see the related object details.

Image RemovedImage Added

Order / Session backtrace customizing

...

It is possible to create a dedicated string for each message and state type. It is also possible to put a field value into the string.

Image RemovedImage Added

Order Blotter

You can check the recent status of orders from the loaded files using Order Blotter.

  • On the Tools menu, click Order Blotter.
  • Double-click the selected order to open the Order Backtrace Diagram window.

Image RemovedImage Added


Export

Export backtrace data

You can export data from Order and Session Backtrace diagrams as an image or a plain text.

  • In the Order Backtrace Diagram or Session Backtrace Diagram window, on the File menu, point to Export, and then click Export Data if you want to save messages in text format or click Export Image if you want to save a diagram.

Image RemovedImage Added

Export table data

...

  • Select rows in the table.
  • Right-click the selected rows, and then click Export.

Image RemovedImage Added