Page tree
Skip to end of metadata
Go to start of metadata

Product overview

FIXEye is a multi-purpose FIX session surveillance and visibility platform.

FIXEye presents search results in an easy to work with form. It has intuitive graphical user interface and uses many operational features familiar from MS Excel.

FIXEye can process multiple log-files distributed on the network.

FIXEye features

  • Search for FIX log-files on a local computer and a whole network
  • Show FIX messages in a table
  • Select FIX fields to be shown in a table
  • Show FIX field names, values and descriptions
  • Filter FIX messages by particular text in fields
  • Recognize all FIX versions from a log file
  • Support Regular expression
  • Read raw FIX messages from any text files (not cleaned FIX-logs only)
  • Filter FIX messages by sessions
  • Provide context search
  • Create custom views
  • Create custom filters
  • Validate FIX messages
  • Compare FIX messages
  • Support FIX dialects
  • Provide Order back trace
  • Support Multi-tab view
  • Export selected cells to CSV

FIXEye main window

  

Starting FIXEye

Quick start

  • To start FIXEye, click Start, point to All Programs, click B2BITS, and then click FIXEye. You can also double-click the FIXEye icon.
  • To choose data files, on the File menu, click Open Log Files, select files with raw FIX messages and click Open.
  • Write a search query in a search box and click Search.
  • Double-click on a message in the table to see FIX message details.

At the very beginning FIXEye displays a dialog form for opening log files. You can either browse for files by clicking the corresponding step or skip this step by clicking the Cancel button.

Opening file

On the File menu, click Open Log Files or Open Log Folder.

You can also use the button on your toolbar.

Sending to FIXEye

You can send log files to FIXEye from any folder on your computer.

  • Right-click a folder, point to Send To, and then click FIXEye.
  • The sent files will be opened in a new instance of FIXEye.

Multiple tabs

FIXEye allows creating multiple data windows (tabs). It is possible to specify different search text, filter and view for each data window.

  • To add a new tab, click the New message view button. You can also press Ctrl+T.
  • New data window with a clear search box will appear next to the current one.

Data search

Select the type of message you want to find, type your search query in any search box in the main window and hit the Search button.

You can stop the search process by clicking the Cancel button on the status bar.

Search results (namely messages) are sorted by relevance to the specified search terms.
Search terms are indicated on the data window label and placed into the search box as well.

You can search for a specific context in a raw message.

  • Double-click on a message to open the Message Details window and enter your search query in the search text box.
  • Press Enter to go to the next search result or Shift+Enter to return to the previous one.

Messages

Agent

You can use an agent to browse log files on any remote computer if security or any other issues prevent your direct access to the machine.

  • Right-click anywhere in the Files window, and then click Add Agent. You can also use the Add Agent button.
  • In the Agent Connection Parameters dialog, enter your connection parameters, and then click Create.

Please note that the agent should already be installed, configured and run on the remote computer.

If connection is available and everything is setup properly, your agent status will change to “Connected”.

  • You can see which files you can browse and what dictionaries the agent uses in the corresponding sub-lists.
  • You can browse only static files. No changes in logs will be reflected.
  • If you want browse logs real-time, please see the Watch section.

Please note that the agent should already be installed, configured and run on the remote computer.

Message details

To view message details:

  • Right-click the selected FIX message, and then click Show Message Details. You can also double-click the selected FIX message.

Comparing messages

You can compare two messages tag by tag in a separate window.

  • Select a message, and then hold down Ctrl key while you click other message you want to select.
  • Right-click the selected message, and click Compare Messages.

Please note, that if you select more than two messages, FIXEye will compare only the first and the last one.

You can exclude separate tags from the comparison.

  • In the Message Compare dialog, in the Exclusive tags, type the tags with any delimiter, and then click the Compare button to refresh the list.

= values are identical
<> values are different
<= tag is present only in the left message
=> tag is present only in the right message

Comparing files

You can compare two log files message by message using our new Files Compare tool.

  • On the Tools menu, click Files Compare.
  • Click the Browse at the end of each line to select the files you want to compare.
  • Click the Compare.

“<>” indicates that messages are different

  • Click the <> to compare 2 messages in a new window.

Message sorting

You can sort messages in ascending or descending order.

  • Click the appropriate table column header to sort messages.
  • The direction of the arrow next to the header name indicates the direction of the sort.
  • You can reset current sorting by pressing <Esc>.

Message auto filter

You can use different filters to show or hide specific messages.

  • Click the arrow next to header name, and then select a required value to apply auto filter.
  • To reset filtering, select (All).

  • Click the arrow next to header name, and then select (Custom).
  • Set up a condition operator and a criterion <value> to compare the current FIX field with some value(-s).
  • The filter criteria can either be selected from the drop-down list or entered by the user.

Additional tools

Watch

FIXEye provides a powerful real-time monitoring tool – Watch. You can create multiple processes with various filters and search parameters to follow updates in selected files.

  • To create a new Watch, on the File menu, click Create Watch. You can also click the button on the toolbar to open the Realtime Files Watch window.

  • Specify the message type you want to watch in the Filter list.
  • In the Search box, type search parameters. You can leave the box empty to see all messages.
  • In the Validation list, select a required validation level.
  • In the Check interval box, type a check interval in milliseconds.
  • In the Schedule list, select the moment when you would like to start.

  • To add files you want to watch, under Files, click Open. Select files you want to monitor, and then click Open. You can also add files to the list by typing a file path, and then click Add.
  • To remove a file from the list, select a required file, and then click Remove.
  • Select the E-mail Notifications check box if you want to receive a notification email every time a new message is detected. Click the Configure to set up an outgoing mail server.
  • Select the Activate on new message check box if you want FIXEye to blink on a taskbar when a new message is detected.

You can stop or pause the process in the Realtime Files Watch window using the correspondent buttons on the Watches toolbar.

  • Click the Now Scroll is: Off to switch off the automatic scroll to the latest messages. Clicking the Now Scroll is: On button will restore it.
  • Click the button on the toolbar to clear the list.

You can add an agent to monitor the files on a remote computer.

  • In the Realtime Files Watch dialog, right-click anywhere in the Files window, and then click Add Agent. You can also use the button. Please mind that the agent should already be configured on a remote computer.
  • Once the agent is connected you can add a Watch that will monitor the remote storage

 

FIX Events Viewer

You can create a subscription to the following FIX session events:

  • Session status changes
  • Delayed order acknowledge time is detected
  • On the Tools menu, click Events Viewer. You can also use the Events Viewer button on the toolbar.
  • In the FIX Events Viewer dialog, add files or agents you want to track.
  • Create a subscription.

Click the button on the FIX Events toolbar and select your subscription type.

  • You can opt for notifications of a general status change or change to a concrete state.

  • You can configure notifications precisely by selecting the operator, value and unit of measurement.

You can receive notification emails on every FIX session event.

  • Select the E-mail Notifications check box.
  • Click the Configure to set up an outgoing mail server.

Interface

File list

All opened log files are listed in the Files window.

  • Select the respective file check box to include the file content in the next search.
  • Clear the respective file check box to exclude the file content from the next search.

Dictionaries list

FIXEye covers standard FIX-features by default, but you can work with non-standard FIX-dialects after loading special files (XML-format) that contain the necessary descriptions.

  • To add a dictionary file, on the File menu, click Load Dictionaries. You can also right-click anywhere in the Files window, and then click Add Dictionary(ies).
  • To remove a dictionary file, right-click the selected file, and click Remove Dictionary(ies).

    

Sessions list

All sessions found in opened log files are listed in the Sessions window.

  • Create groups to sort your sessions using a context menu.
  • Select a session check box to include the respective session in the next search.
  • Clear a session check box to exclude the respective session from the next search.

Customizing interface

You can adjust the viewing depending on how you arrange the windows in the FIXEye. The following options are just some of the ways that windows can be arranged:

  • Tab-dock windows to the search result frame.
  • Dock tool windows to the edge of a frame in the FIXEye.
  • Float windows over or outside the FIXEye.
  • Minimize tool windows along the edge of the FIXEye.

   

Tool windows can be docked to one side of a frame in the FIXEye:

  • Drug the window toward the middle of FIXEye window. Three arrows appear and point to the three edged of FIXEye window. The diamond only appears when you drag the window toward another tool window.
  • When the window you are dragging reaches the location where you want to dock it, the designated area is shaded.
  • To dock the window in the position indicated, release the mouse button.

Tool windows such as Files and Sessions support a feature named Auto-Hide. When a window is auto-hidden, its name and icon are displayed on a tab at the edge of the FIXEye.
To turn on Auto-Hide:

  • Click the tool window you want to hide.
  • Click the pushpin icon on the title bar of the window.

To Turn off Auto-Hide:

  • Click the window you want to keep visible.
  • Click the pushpin icon on the title bar of the window.

Tool windows can be undocked from the FIXEye and moved anywhere on the desktop.

  • Drug the tool window to the location you want.

Data filter

You can use different filters to show specific messages only.

  • In the Filter list, click a filter you want to apply.

Do one of the following:

  • To create a new filter, click <New>.
  • To modify the selected filter, click the Edit button.
  • To remove the selected filter, click the Remove button.
  • To reset the current filter, click [Default Filter].

When you are creating a new filter, you may indicate one or more conditions.

You can save a back copy of the current filter by clicking button in the Filter window.

You can address a field tag, which is a part of a repeating group while creating a new filter.

  • Type a repeating group tag, then type a dot character “.”, and a field tag. For example, 453.452 indicates that messages with a repeating group tag of 453 that includes tag of 452 will be filtered.

Custom view

You can customize a message view (a set of displayed columns) in the table.

  • In the View list, click a view you want to apply.

Do one of the following:

  • To create a new view, click <New>.
  • To modify the selected view, click the Edit button.
  • To remove the selected view, click the Remove button.
  • To reset the current view, click [Default View].

The “Compact” preset view allows showing messages in a compact form, i.e. numbers for tags and values without description.
The “Detailed” preset view allows showing maximum information about messages. All tag names except service fields are displayed and all field values are described.
The “Raw Data” preset view allows displaying messages in their raw view, i.e. as a row of symbols.

The “Colored” preset view allows displaying messages in different colors, i.e. a particular color is assigned to every message type, to facilitate visual perception of table data.

When you are creating a new view, you may indicate one or more conditions. Use to add fields and formatting rules and to delete them.

Validation

Message validation

You can validate messages in the table against FIX rules.

  • Click n and choose the validation that you want.

There are 3 levels of validation:

  • Well formed – message length and checksum match the corresponding field values
  • Well formed and required fields – the same as above and all mandatory fields are present in a message
  • Well formed and required fields and correct values – the same as above, plus message fields have correct values (e.g. numeric field has a numeric value, date field has some sensible date etc)

Invalid messages are marked in the table with icon.
Related error descriptions are placed into Errors tab of this data window.

  • Double-click the icon to see the detailed description of an error.

Order backtrace

This feature shows a trade process as a chart of its states defined by related FIX-messages.

  • Right-click on the selected message, and then click Order Backtrace.

Click on a message or a state shape to see the related object details.

Session backtrace

This feature shows a session process as a chart consisting of its states defined by related Logon and Logout messages and Test Requests.

  • Right-click on the selected message, and then click Session Backtrace.

Click on a message or a state shape to see the related object details.

Order / Session backtrace

You can customize text displayed in shapes.

  • In the Session Backtrace Diagram window, on the Tools menu, click Options.
  • In the Order Backtrace Diagram window, on the Tools menu, click Options.

It is possible to create a dedicated string for each message and state type. It is also possible to put a field value into the string.

Order Blotter

You can check the recent status of orders from the loaded files using Order Blotter.

  • On the Tools menu, click Order Blotter.
  • Double-click the selected order to open Order Backtrace Diagram window.

Export

Exporting backtrace data

You can export data from Order and Session Backtrace diagrams as an image or a plain text.

  • In the Order Backtrace Diagram or Session Backtrace Diagram window, on the File menu, point to Export, and then click Export Data if you want to save messages in text format or click Export Image if you want to save a diagram.

Exporting table data

You can export table data to a separate text file (.csv or .fix)

  • Select rows in the table.
  • Right-click the selected rows, and then click Export.

  • No labels